Installation#

Pre-requisites#

CoFI requires Python 3.7+, and the following dependencies:

  • numpy>=1.18

  • scipy>=1.0.0

  • emcee>=3.1.0

  • arviz>=0.9.0

  • findiff>=0.7.0

  • torch>=1.10

Install#

$ pip install cofi

Uploading to conda-forge is still work in progress.

It won’t be long!

If you’d like to build from source, clone the repository

$ git clone https://github.com/inlab-geo/cofi.git
$ cd cofi

And use either one of the following command to install

$ pip install .         # library will be copied over to site-packages
$ pip install -e .      # developer mode, library will be symbol linked to site-packages

Hint

CoFI time! Check out our step-by-step tutorials or examples to get started.